ScootKit - Missing Servers in Dashboard – Incident details

All systems operational

Missing Servers in Dashboard

Resolved
Major outage
Started 3 days agoLasted about 1 hour

Affected

SCNX

Operational from 3:25 PM to 3:33 PM, Degraded performance from 3:33 PM to 4:46 PM

SCNX Backend

Operational from 3:25 PM to 3:33 PM, Degraded performance from 3:33 PM to 4:46 PM

Updates
  • Postmortem
    Postmortem

    Summary of the Event

    Earlier today, many of you noticed that servers where you hold Administrator permissions (but are not the server owner) suddenly disappeared from your management dashboard. We want to clarify that this bug not only hid the servers from your view but also locked your access to manage them through our interface.

    Please be assured that this was strictly a dashboard authorization issue. All of your hosted bots and automated systems remained online and functioned perfectly throughout this incident.

    What Happened & Why

    This issue was caused by a backend update we rolled out yesterday. We updated our systems to use Discord’s latest API version (v10) to ensure future stability.

    However, we missed a critical detail: in older versions of their API, Discord sent user permissions in a specific background format (a data field called permissions_new). In v10, Discord completely dropped this legacy field. Because our dashboard's background logic was still explicitly looking for the old format, it read everyone's admin permissions as "0". As a security precaution, when our system reads "0" permissions, it defaults to hiding the server and locking dashboard access to it.

    Why Our QA Missed This

    We take full responsibility for this slipping through to production. Our Quality Assurance (QA) process absolutely should have caught this before the update went live yesterday. It didn't because our older testing procedures only verified dashboard access for Server Owners and users with specific Trusted Admin permissions. Because both of those permission types use different verification logic, they were completely unaffected by the API change, keeping the bug hidden during our automated and manual tests.

    How We Reacted

    • Issue Detection: Once the update went live, we began receiving an increased volume of support tickets regarding missing servers.

    • Investigation: Our engineering team immediately began investigating the reports to find a common denominator, identifying that it only affected non-owner admins.

    • Identification: We traced the bug to the GET /users/@me/guilds Discord API endpoint and pinpointed the missing permissions_new field.

    • Resolution: We updated our backend logic to read Discord's current, official permissions format and deployed the fix to production.

    What You Need to Do

    The fix is completely rolled out on our end. To regain access and see your missing servers again, you need to make sure your browser loads the newest version of the dashboard:

    • Perform a hard refresh of the page (Press Ctrl + F5 on Windows or Cmd + Shift + R on Mac).

    • Alternatively, you can clear your browser cache.

    Looking Ahead

    • QA Process Update: We have immediately updated our QA testing protocols to explicitly include standard Administrator permission checks alongside Owner and Trusted Admin checks.

    We apologize for the frustration this caused and appreciate you bringing it to our attention so quickly!

  • Resolved
    Resolved

    We have confirmed that the fix for the missing servers in the dashboard is fully operational and this incident is now resolved.

    If you still do not see your servers, please remember to perform a hard refresh (Ctrl + F5 / Cmd + Shift + R) or clear your browser cache.

    As a final reminder, all hosted bots and systems were unaffected by this visual bug and continue to work perfectly. Thank you for your patience and understanding while we sorted this out!

  • Monitoring
    Monitoring

    We have successfully rolled out a fix for the issue that prevented servers from appearing in the dashboard for users with Administrator permissions. We are currently monitoring the situation to ensure everything is functioning correctly.

    Important: To see your missing servers again, you will need to perform a hard refresh of the dashboard page (Ctrl + F5 / Cmd + Shift + R) or clear your browser cache.

    As a reminder, all hosted bots and systems remain fully operational and working without any issues. Thank you for your patience while we resolved this!

  • Identified
    Identified

    We have successfully identified the root cause of the issue preventing some servers from appearing in the dashboard for users with Administrator permissions. The problem was related to a recent change in how permissions are formatted in the underlying Discord API.

    Our team is currently implementing and deploying a fix. All hosted bots and systems continue to be fully operational and unaffected by this dashboard issue. We will update this page again as soon as the fix is fully rolled out and the dashboard is back to normal.

  • Investigating
    Investigating

    We are currently receiving an increased number of reports regarding missing servers in the dashboard. Specifically, users are unable to see servers where they hold Administrator permissions but are not the server owner.

    Our team is actively investigating these reports to identify the root cause. At this time, we have not yet been able to reproduce the issue on our end. Please note that all hosted bots and underlying systems are fully operational and working without any issues. We are monitoring the situation closely and will provide further updates as soon as we have more information or a potential fix. Thank you for your patience while we work on this.