ScootKit - Important Warning for all Beta Testers: Please DO NOT use the Lockdown feature right now! 🚨 – Incident details

All systems operational

Important Warning for all Beta Testers: Please DO NOT use the Lockdown feature right now! 🚨

Resolved
Degraded performance
Started 5 months agoLasted about 3 hours

Affected

SCNX

Degraded performance from 1:25 PM to 3:57 PM

SCNX Bot-Manager

Degraded performance from 1:25 PM to 3:57 PM

Updates
  • Resolved
    UTC
    Resolved

    This has been fixed in the BETA-v3.22.1-6 version: https://scnx.app/de/changelogs/beta-v3.22.1-6

    Before using the lockdown feature, ensure that you have upgraded your bot by restarting it in the dashboard.

  • Identified
    UTC
    Identified

    Hi everyone,

    Thanks to a quick report from our community, we've identified a critical bug in the current beta version. When executing a "Lockdown", there is an issue where your lockdown data might not be saved properly. Unfortunately, this results in permanent data loss, e.g. channel permissions being lost and having to reconfigure them manually.

    To prevent this from happening to anyone else, please avoid using the Lockdown feature entirely until the next patch is released!

    The good news: We have already found and fixed the underlying issue. The process has been rebuilt so that the lockdown will only trigger after the system has successfully confirmed the data save.

    A patch is on the way and will hopefully be released later today. We will ping you here as soon as the update is live and the feature is safe to use again.

    Thank you for your patience, and a massive thank you to everyone helping us find and squash these bugs during the beta phase. Your support means the world to us! 💛